ТекущаяШирина=Элементы.ИгровоеПоле.ПодчиненныеЭлементы.Количество();
Если ТекущаяШирина=0 Тогда ТекущаяВысота=0;
Иначе
Колонка=Элементы.ИгровоеПоле.ПодчиненныеЭлементы.Получить(0);
ТекущаяВысота=Колонка.ПодчиненныеЭлементы.Количество();
КонецЕсли;
НомерКолонки=ТекущаяШирина;
Пока НомерКолонки>0 Цикл
НомерСтроки=ТекущаяВысота;
Пока НомерСтроки>0 Цикл
Если НомерСтроки>Объект.Высота или НомерКолонки>Объект.Ширина Тогда
Элемент=Элементы.Найти("Ячейка_"+НомерКолонки+"_"+НомерСтроки);
Элементы.Удалить(Элемент);
КонецЕсли;
НомерСтроки=НомерСтроки-1;
КонецЦикла;
Если НомерКолонки>Объект.Ширина Тогда
Элемент=Элементы.Найти("Колонка"+НомерКолонки);
Элементы.Удалить(Элемент);
КонецЕсли;
НомерКолонки=НомерКолонки-1;
КонецЦикла;


117 Kb, скачали 20, просмотрели 6, тип файла exe


Поделиться в социальных сетях
© 2018 GruzimFile.ru 6.282 сек.